Status Code | Meaning | Handling Recommendation |
0 | The request ends before the status code returned to the request is obtained. | Check whether the client actively disconnects the request too early, or check whether the origin pull fails. |
400 | HTTP request syntax error The server cannot parse it. | Check whether the request syntax is correct. |
403 | Access denied | Check the hotlink protection, authentication configuration, and UA allowlist/blocklist in the CDN console. |
404 | The server cannot return correct information. | Check whether the origin server is normal or whether the origin server information and origin-pull HOST configuration have changed. For details, see CDN domain name suddenly returns 404 status. |
413 | POST length exceeds the limit | Check the client POST content size (the default size limit is 32 MB). |
414 | URL length exceeds the limit | The default URL size limit is 2 KB. |
418 | Configuration file cannot be read. | Origin server response: Test by directly accessing the origin server. If the origin server responds with 418, modify the origin server configuration or the client request behavior to obtain a correct response. Node response: After a domain name is connected to the CDN, the system automatically assigns service nodes to the domain name, and the corresponding nodes deliver the configuration file for the domain name. When a request reaches a CDN node, if the configuration file does not exist, the node responds with the 418 status code. Check the configuration or check whether the request is a malicious request caused by traffic hijacking. |
423 | Loopback request | Check the origin-pull 301/302 follow configuration, the HTTPS origin-pull method configuration, and the origin server rewrite handling method. |
499 | Client actively disconnects the connection. | Check the client status or timeout settings. |
502 | Gateway error | Check whether the origin server is normal. |
503 | Triggering COS frequency control | Check the cache configuration or the no-cache/no-store headers returned by the COS origin server. |
504 | Gateway timeout | Contact the website administrator. |
509 | Blocked due to triggering CC attack. | |
514 | Exceeding IP address access frequency limit | Check the IP address access frequency limit configuration in the CDN console. |
524/614 | Triggering platform access overload | A sudden surge in service requests can trigger platform overload. Evaluate the service volume and report it to Tencent Cloud. Contact after-sales support if you have any questions. |
531 | HTTPS origin-pull domain name resolution error | Check the origin server domain name resolution configuration. |
532 | HTTPS origin-pull connection establishment failure | Check the status of the origin server's port 443 and its certificate configuration, or check the origin server availability. |
533 | HTTPS origin-pull connection timeout | Check the status of the origin server's port 443 and its certificate configuration, or check the origin server availability. |
537 | HTTPS origin-pull data reception timeout | Check the origin server stability. |
538 | HTTPS SSL handshake failure | Check the compatibility of the origin server protocol and algorithm. |
539 | HTTPS certificate verification failure | Check whether the origin server certificate is properly configured (whether it has expired, and whether the certificate chain is complete). |
540 | HTTPS certificate domain name verification failure. | Check whether the origin server certificate is properly configured. |
562 | HTTPS connection establishment failure | |
563 | HTTPS connection timeout | |
564 | HTTPS origin-pull failure | If the origin-pull method is configured as HTTP, check the origin server load and bandwidth utilization, or the origin server access restrictions. If the origin-pull method is configured as protocol following, check the status of the origin server's port 443 and its certificate configuration. If no abnormality is found after the origin server is troubleshooted, contact us and provide the X-NWS-LOG-UUID information, or submit a ticket for troubleshooting. |
567 | Response timeout while the node is receiving a file. |
Status Code | Meaning |
100 | The server has received the request headers, and the client should proceed to send the request body (in the case of requests that require a body: for example, a POST request), or if the request is already complete, ignore this response. The server must send a final response to the client after the request is completed. For the server to check the request headers, the client must send Expect: 100-continue as a header in its initial request and receive a 100 Continue status code before it sends the body. Response code |
101 | The server has understood the client's request and will notify the client via the Upgrade header to adopt a different protocol to complete this request. After sending the final empty line of this response, the server will switch to the protocols defined in the Upgrade header. Such measures should only be taken when it is more beneficial to switch to a new protocol. For example, switching to a new HTTP version (such as HTTP/2) offers advantages over the old version, or switching to a real-time and synchronous protocol (such as WebSocket) to deliver resources that leverage such features. |
102 | A WebDAV request may contain many sub-requests involving file operations, requiring a long time to complete the request. This code indicates that the server has received and is processing the request, but no response is available. This prevents the client from timing out and assuming the request is lost. |
103 | Used to return some response headers before the final HTTP message. |
200 | The request has succeeded. The desired response headers or body will be returned with this response. In a GET request, the response contains an entity corresponding to the requested resource. In a POST request, the response contains an entity describing or resulting from the operation. |
201 | The request has been fulfilled, and a new resource has been created according to the needs of the request, with its URI returned in the Location header. If the required resource cannot be created in time, '202 Accepted' should be returned. |
202 | The server has accepted the request but has not processed it. Ultimately, the request may or may not be executed, and it may be prohibited when processing is being performed. |
203 | The server is a transforming proxy (such as a network accelerator) that originates from a 200 OK status code but returns a modified version of the original response. |
204 | The server successfully processed the request and returned no content. In the captive portal feature, when a Wi-Fi device connects to a Wi-Fi access point that requires web authentication, it accesses a website that can generate an HTTP 204 response. If a 204 response is received normally, it indicates that web authentication is not required. Otherwise, a web browser page pops up, displaying a web authentication page for user authentication and login. |
205 | The server successfully processed the request but returned no content. Unlike a 204 response, this response requires the requester to reset the document view. |
206 | The server has successfully processed a partial GET request. HTTP download tools like FlashGet or Xunlei use this type of response to implement resumable downloads or to split a large document into multiple segments for simultaneous downloading. |
207 | Indicates that the subsequent message body will be an XML message and may contain a series of independent response codes, depending on the number of previous sub-requests. |
208 | The members bound to DAV have already been enumerated in the part preceding the (multi-status) response and are not included again. |
226 | The server has fulfilled the request for the resource, representing the result of one or more entity operations on the entity request. |
300 | The requested resource has a series of alternative feedback options, each with its own specific address and browser-driven negotiation information. The user or browser can independently select a preferred address for redirection. |
301 | Permanent move. The requested resource has been permanently moved to a new URI. The response information includes the new URI, and the browser automatically redirects to it. Any future requests should use the new URI instead. |
302 | Temporary movement. Similar to 301, but the resource is only temporarily moved. The client should continue to use the original URI. |
303 | The response to the current request can be found at another URI. When a response is received for a POST (or PUT/DELETE) request, the client should assume that the server has received the data and should issue a redirect using a separate GET message. |
304 | Indicates that the resource has not been modified since the version specified by the If-Modified-Since or If-None-Match parameters in the request header. In this case, because the client still has a previously downloaded copy, it does not need to retransmit the resource. |
305 | The requested resource must be accessed through a specified proxy. The Location header field provides the URI of the specified proxy. The recipient needs to resend a separate request through this proxy to access the corresponding resource. |
306 | In the latest version of the specification, the 306 status code is no longer used. It originally meant "subsequent requests should use the specified proxy". |
307 | In this case, the request should be repeated with another URI, but subsequent requests should still use the original URI. Unlike 302, when the original request is resent, the request method is not allowed to be changed. For example, a POST request should be repeated with another POST request. |
308 | The request and all future requests should be repeated with another URI. Status codes 307 and 308 repeat the behavior of 302 and 301, but do not allow the HTTP method to be changed. For example, submitting a form to a permanently redirected resource may proceed smoothly. |
401 | Similar to 403 Forbidden, the semantics of 401 is "unauthorized", meaning the user lacks the necessary credentials. |
405 | The request method specified in the request line cannot be used for the requested resource. The response must return an Allow header to indicate the list of request methods that the current resource can accept. |
406 | The content characteristics of the requested resource cannot satisfy the conditions in the request header, therefore a response entity cannot be generated, and the request is unacceptable. |
407 | Similar to a 401 response, except that the client must authenticate with the proxy server. |
408 | Request timeout. According to the HTTP specification, the client did not complete sending a request within the time the server was prepared to wait. The client can resubmit this request at any time without making any changes. |
409 | Indicates that the request cannot be processed due to a conflict, such as an edit conflict between multiple concurrent updates. |
410 | Indicates that the requested resource is no longer available. This status code is used when a resource has been intentionally removed and should be purged. After receiving a 410 status code, the user should stop requesting the resource again. However, most servers do not use this status code and instead directly use the 404 status code. |
411 | The server refuses to accept the request without a defined Content-Length header. After adding a valid Content-Length header that indicates the length of the request message body, the client can resubmit the request. |
412 | The server failed to meet one or more preconditions specified in the request header fields during validation. This status code allows the client to set preconditions in the request's meta-information (request header field data) when a resource is obtained, thereby preventing the request method from being applied to resources other than the intended content. |
415 | For the method of the current request and the requested resource, the internet media type submitted in the request is not a format supported by the server, therefore the request is rejected. For example, the client uploads an image in svg format, but the server requires images to be uploaded in jpg format. |
416 | The client has requested a portion of the file, but the server cannot provide that portion. For example, if the client requests a portion of the file that extends beyond the end of the file. |
417 | The expected content specified in the Expect request header cannot be satisfied by the server, or the server is a proxy server that has clear evidence that the content of Expect cannot be satisfied at the next node on the current route. |
500 | A generic error message indicating that the server encountered an unexpected condition that prevented it from fulfilling the request. No specific error information is provided. |
501 | The server does not support a feature required by the current request. This occurs when the server cannot recognize the request method and is unable to support its request for any resource. |
505 | The server does not support, or refuses to support, the HTTP version used in the request. This implies that the server cannot or is unwilling to use the same version as the client. The response should contain an entity that describes why the version is not supported and which protocols the server does support. |
508 | The server enters an infinite loop while processing the request. |
510 | The policy required to obtain the resource has not been satisfied. |
Was this page helpful?
You can also Contact sales or Submit a Ticket for help.
Help us improve! Rate your documentation experience in 5 mins.
Feedback