tencent cloud

Cloud Virtual Machine

DocumentaçãoCloud Virtual Machine

Descrição de compatibilidade e configuração da ferramenta

Baixar
Modo Foco
Tamanho da Fonte
Última atualização: 2026-09-07 14:18:02
Traduzido por IA

Sistemas operacionais suportados

Atualmente, os sistemas operacionais de servidor de origem compatíveis com a ferramenta de migração online incluem, entre outros, os seguintes sistemas operacionais (recomenda-se prestar atenção à versão mínima do sistema compatível):
Sistema operacional Linux
Sistema operacional Windows
CentOS 5/6/7/8
Windows Server 2008R2
Windows Server 2012
Windows Server 2016
Windows Server 2019
Windows Server 2022
Windows Server 2025
Ubuntu 10/12/14/16/18/20/22/24/26
Debian 7/8/9/10/12
SUSE 11/12/15
openSUSE 42/Leap-15
Amazon Linux AMI
Red Hat 5/6/7/8/9/10
Oracle Linux 5/6/7/8/9

Modos de migração suportados

Modo de migração pela internet pública
Modo de migração pela rede interna
Se tanto o servidor de origem quanto o servidor em nuvem de destino tiverem capacidade de acesso à Internet pública, você poderá usar o modo de migração pela Internet pública para realizar a migração.
No modo atual de migração pela Internet pública, o servidor de origem acessa a API da Tencent Cloud pela Internet para iniciar a solicitação de migração e transmite dados para o servidor em nuvem de destino, migrando o servidor de origem para o servidor em nuvem de destino da Tencent Cloud. O cenário de migração pela Internet pública é mostrado na figura a seguir:

Se o servidor de origem ou o servidor em nuvem de destino estiver em uma intranet ou VPC, e o servidor de origem não puder estabelecer conexão diretamente com o servidor em nuvem de destino pela Internet, você poderá usar o modo de migração pela intranet da ferramenta. O modo de migração pela intranet exige o estabelecimento de um canal de conexão entre o servidor de origem e o servidor em nuvem de destino por meio de métodos como conexão de emparelhamento de VPC, conexão VPN, Cloud Connect Network ou acesso dedicado.
Cenário 1: (Este cenário só é compatível com migração usando a ferramenta) Se o servidor de origem ou o servidor em nuvem de destino não tiver acesso à Internet pública, você poderá primeiro usar um servidor com capacidade de acesso à Internet pública (como um gateway) para acessar a API da Tencent Cloud pela Internet e iniciar a solicitação de migração e, em seguida, transmitir dados para o servidor em nuvem de destino por meio de um canal de conexão para realizar a migração. Este cenário não exige que o servidor de origem e o servidor em nuvem de destino tenham capacidade de acesso à Internet pública.

Cenário 2: Se o servidor de origem tiver acesso à Internet pública, você poderá primeiro acessar a API da Tencent Cloud pela Internet no servidor de origem para iniciar a solicitação de migração e, em seguida, transmitir dados para o servidor em nuvem de destino por meio de um canal de conexão para realizar a migração. Este cenário exige que o servidor de origem tenha capacidade de acesso à Internet pública, mas não exige o mesmo do servidor em nuvem de destino.

Cenário 3: Se o servidor de origem puder acessar a Internet pública por meio de um proxy, você poderá primeiro acessar a API da Tencent Cloud por meio do proxy de rede no servidor de origem para iniciar a solicitação de migração e, em seguida, transmitir dados para o servidor em nuvem de destino por meio de um canal de conexão para realizar a migração. Este cenário não exige que o servidor de origem e o servidor em nuvem de destino tenham capacidade de acesso à Internet pública.


Descrição do arquivo compactado

Após descompactar o go2tencentcloud.zip, a descrição dos arquivos é a seguinte:
Nome do arquivo
Descrição
go2tencentcloud-linux
Diretório de ferramentas de migração do sistema Linux.
go2tencentcloud-windows
Migração do sistema Windows.
readme.txt
Arquivo de introdução ao diretório.
release_notes.txt
Registro de alterações da ferramenta de migração.
A descrição dos arquivos do diretório da ferramenta de migração go2tencentcloud-linux é a seguinte:
Nome do arquivo
Descrição
go2tencentcloud_x64
Programa executável da ferramenta de migração para sistemas Linux de 64 bits com arquitetura x86.
go2tencentcloud_x32
Programa executável da ferramenta de migração para sistemas Linux de 32 bits com arquitetura x86.
go2tencentcloud_arm64
Programa executável da ferramenta de migração para sistemas Linux de 64 bits com arquitetura arm.
tools
Diretório de arquivos de dependência da ferramenta de migração.
logs
Diretório de logs da ferramenta de migração.
user.json
Informações do usuário durante a migração.
client.json
Arquivo de configuração da ferramenta de migração durante a migração.
rsync_excludes_linux.txt
Arquivo de configuração para excluir arquivos ou diretórios que não precisam ser migrados no sistema Linux.
A descrição dos arquivos do diretório da ferramenta de migração go2tencentcloud-windows é a seguinte:
Nome do arquivo
Descrição
go2tencentcloud_x64.exe
Programa executável da ferramenta de migração para sistemas Windows de 64 bits.
logs
Diretório de logs da ferramenta de migração.
user.json
Informações do usuário durante a migração.
client.json
Arquivo de configuração da ferramenta de migração.
client.exe
Programa executável de migração para sistemas Windows.
Atenção:
Não exclua o arquivo de configuração e armazene-o no mesmo diretório do programa executável go2tencentcloud.

Descrição do arquivo rsync_excludes_linux.txt

Exclua os arquivos que não precisam ser migrados ou transferidos do servidor de origem Linux ou especifique os arquivos de configuração no diretório. Os seguintes diretórios e arquivos já foram excluídos por padrão neste arquivo. Não os exclua nem modifique.
/dev/*
/sys/*
/proc/*
/var/cache/yum/*
/lost+found/*
/var/lib/lxcfs/*
/var/lib/docker-storage.btrfs/root/.local/share/gvfs-metadata/*
Se você precisar excluir outros diretórios e arquivos, adicione o conteúdo ao final deste arquivo. Por exemplo, exclua todo o conteúdo do disco de dados montado em /mnt/disk1.
/dev/*
/sys/*
/proc/*
/var/cache/yum/*
/lost+found/*
/var/lib/lxcfs/*
/var/lib/docker-storage.btrfs/root/.local/share/gvfs-metadata/*
/mnt/disk1/*

Descrição dos parâmetros de execução da ferramenta

Opções de parâmetros
Descrição
-help
Imprimir informações de ajuda.
-check
Verificar se o servidor de origem atende aos requisitos de migração, apenas verificando sem migrar.
-ignore-check
Pular a verificação automática da ferramenta durante a migração e migrar diretamente.
-log-file
Definir o nome do arquivo de log, o padrão é log.
-log-level
Nível de saída do log, com valores possíveis de 1 (nível ERROR), 2 (nível INFO) e 3 (nível DEBUG). O valor padrão é 2.
-version
Imprimir o número da versão da ferramenta.
-secret-id
SecretId da chave de acesso da conta de destino da API da Tencent Cloud.
-secret-key
SecretKey da chave de acesso da conta de destino da API da Tencent Cloud.
-region
A região de destino para a qual a migração será realizada.
-mode
Modo de rede para transferência de dados, com valores possíveis de 0 (modo de rede pública, transferindo dados pela rede pública), 2 (modo de rede interna cenário 2, transferindo dados pela rede interna) e 3 (modo de rede interna cenário 3, transferindo dados pela rede interna). O valor padrão é 0.
-console
Permitir que a ferramenta crie tarefas e realize a migração automaticamente, sem a necessidade de criar tarefas manualmente no console de migração. Isso é adequado para cenários de migração em lote.
-dest-type
Tipo de destino da migração, com valores possíveis de Image (migrar para uma imagem de servidor em nuvem) e Instance (migrar para uma instância de servidor em nuvem de destino). O valor padrão é Instance.
-instance-id
Ao migrar para uma instância de servidor em nuvem, o ID da instância de servidor em nuvem de destino para a qual a migração será realizada.
-out-image-name
Ao migrar para uma imagem de servidor em nuvem, defina o nome da imagem.
-dest-vpc-id
Ao usar o modo de rede interna para migrar para uma imagem de servidor em nuvem, o ID da VPC que já está conectada ao ambiente de rede interna do servidor de origem.
-dest-subnet-id
Ao usar o modo de rede interna para migrar para uma imagem de servidor em nuvem, o ID da sub-rede que já está conectada ao ambiente de rede interna de origem.
-proxy-ip
Quando o servidor de origem acessa a rede pública por meio de um proxy HTTP, defina o IP do proxy HTTP para a ferramenta.
-proxy-port
Quando o servidor de origem acessa a rede pública por meio de um proxy HTTP, defina a porta do proxy HTTP para a ferramenta.
-proxy-user
Quando o servidor de origem acessa a rede pública por meio de um proxy HTTP, defina o nome de usuário do proxy HTTP para a ferramenta.
-proxy-password
Quando o servidor de origem acessa a rede pública por meio de um proxy HTTP, defina a senha do usuário do proxy HTTP para a ferramenta.
-bandwidth-limit
Defina a largura de banda de limite de velocidade, em KB/s. Por padrão, a ferramenta não impõe limite de velocidade. Aplicável somente à migração do Linux.

Guia para falha na migração

Após a operação de migração de servidor no console, a tarefa pode falhar por alguns motivos. Em caso de falha na tarefa, você pode verificar o código de erro no console e solucionar o problema de acordo com o conteúdo a seguir.
Código de erro
Descrição do erro
Guia
ERROR_REMOTE_INSTANCE_STATUS_NOT_VALID
O status atual da instância do servidor em nuvem de destino da migração não permite a migração.
Somente instâncias com status em execução e desligadas são suportadas como instâncias do servidor em nuvem de destino para migração.
ERROR_SAME_INSTANCE
O servidor de origem e a instância do servidor em nuvem de destino são iguais. A migração não é permitida.
Substitua a instância do servidor em nuvem de destino e reinicie a tarefa de migração.
ERROR_NO_IPV6
O endereço IPv6 da instância do servidor em nuvem de destino está ausente.
A instância do servidor em nuvem de destino não possui um endereço IPv6. Você pode usar um endereço IPv4 para a migração.
ERROR_NO_PUBLIC_IP
A instância do servidor em nuvem de destino não possui IP público, portanto não é possível usar o modo de migração pela rede pública.
A instância do servidor em nuvem de destino não possui IP público, portanto não é possível usar o modo de migração pela rede pública. Você pode atribuir um IP público elástico à instância do servidor em nuvem de destino ou usar o modo de migração pela rede privada.
ERROR_SAME_IP
No modo de migração pela rede interna, o IP interno do servidor de origem e o IP interno da instância do servidor em nuvem de destino são iguais, portanto não é possível estabelecer a conexão.
Você pode usar o modo de migração pela rede pública ou alterar o IP privado da instância do servidor em nuvem de destino.
ERROR_OS_NOT_MATCH
Instâncias Windows e Linux não podem ser migradas entre si.
Instâncias com sistema Windows só podem ser migradas para instâncias Windows. Instâncias com sistema Linux só podem ser migradas para instâncias Linux. Você pode substituir a instância do servidor em nuvem de destino e reiniciar a migração.
ERROR_INSTANCE_TYPE_NOT_SUPPORTED
O tipo de instância da instância do servidor em nuvem de destino não é compatível no momento como destino de migração.
Método 1: Você pode definir o destino da migração como uma imagem do servidor em nuvem. Depois de obter a imagem personalizada, selecione o tipo de instância desejado e crie uma instância com base nessa imagem personalizada.
Método 2: Você pode primeiro migrar para uma instância de outro tipo compatível (como o tipo padrão SA5 etc.). Após a migração, crie uma imagem personalizada e, em seguida, selecione o tipo de instância desejado para criar uma instância com base nessa imagem personalizada.
ERROR_SEC_GROUP_PORT_NOT_OPEN3
As portas 80, 443 e 3389 do grupo de segurança da instância do servidor em nuvem de destino não estão abertas.
Você pode abrir as portas correspondentes do seu grupo de segurança no console.
ERROR_ADD_MORE_DISK
O número de discos de dados da instância do servidor em nuvem de destino é insuficiente.
Você pode aumentar o número de discos de dados da instância do servidor em nuvem de destino para atender aos requisitos de migração.
ERROR_SYSTEM_DISK_SIZE_NOT_ENOUGH
O espaço do disco do sistema da instância do servidor em nuvem de destino é insuficiente.
Você pode expandir o disco do sistema para atender aos requisitos de migração.
ERROR_RUN_INSTANCES_NO_PAYMENT_RIGHTS
A subconta não tem permissão de pagamento.
A conta principal deve acessar o Gerenciamento de Acesso e adicionar a política QCloudFinanceFullAccess à subconta.
ERROR_ENTER_MIGRATE_MODE
Falha ao colocar a instância do servidor em nuvem de destino no modo de migração.
Entre em contato com o atendimento ao cliente para obter assistência.
ERROR_HOST_TO_HOST_CONNECTION
A origem da migração não consegue se conectar à instância do servidor em nuvem de destino.
Entre em contato com o atendimento ao cliente para obter assistência.
ERROR_INIT_SERVER
Falha ao inicializar o servidor de destino.
Entre em contato com o atendimento ao cliente para obter assistência.
ERROR_DATA_TRANSMISSION
Falha na transmissão de dados.
Entre em contato com o atendimento ao cliente para obter assistência.

Ajuda e Suporte

Esta página foi útil?

comentários